Discussions

marked v4

Image

comment importer marked 4.0.19 , l'importation ne fonnctionne pas , il y aurait pas une astuce ? 

8 réponses
Image
MMADI Abdou
Le 24/08/2022 à 12:53

quand npm i marked , ça m'installe la version 4 et il y a un message de not found mais la version 2 fonnctionne bien , pr la version , j'ai compris qu'on doit importer le module et je sais pas comment faire ?

Image
Louis-Nicolas Leuillet
Le 29/08/2022 à 10:26

Hello, vous pouvez utiliser npm i marked@2.1.3

Image
David EGEA
Le 11/10/2022 à 15:39

Je confirme le version marked v4 plante. Par contre avec la version 2.1.3 c'est ok ;)

Image
Antoine Delamare
Le 22/02/2023 à 23:21

Bonjour ! Je rencontre un probleme assez technique lors du déploiement de mon projet React sur le localhost. Le site s'affiche correctement néanmoins la console me retourne le message d'erreur suivant que je ne parvient pas à résoudre : ```Uncaught (in promise) TypeError: Cannot convert undefined or null to object

    at Function.keys (<anonymous>)

    at companion-bubble.js:1465:19716

    at Generator.next (<anonymous>)

    at Ln (companion-bubble.js:1465:19134)```. Comment faire svp ? Merci par avance !

Image
Louis-Nicolas Leuillet
Le 24/02/2023 à 11:13

Je pense qu'il y a un problème avec une valeur que vous essayez d'utiliser ! Puis-je voir ton code ?

Image
Antoine Delamare
Le 24/02/2023 à 12:38 (modifié le 24/02/2023 à 18:29)

Oui bien sur ! Comment puis-je envoyer le code ? Via GitHub ou via ce terminal ?

Voici le contenu de mon fichier 'package.json' ```{

  "name": "react-formation",
  "version": "0.1.0",
  "private": true,
  "dependencies": {
    "@testing-library/jest-dom": "^5.16.5",
    "@testing-library/react": "^13.4.0",
    "@testing-library/user-event": "^13.5.0",
    "react": "^18.2.0",
    "react-dom": "^18.2.0",
    "react-scripts": "5.0.1",
    "styled-components": "^5.3.6",
    "web-vitals": "^2.1.4"
  },
  "scripts": {
    "start": "react-scripts start",
    "build": "react-scripts build",
    "test": "react-scripts test",
    "eject": "react-scripts eject"
  },
  "eslintConfig": {
    "extends": [
      "react-app",
      "react-app/jest"
    ]
  },
  "browserslist": {
    "production": [
      ">0.2%",
      "not dead",
      "not op_mini all"
    ],
    "development": [
      "last 1 chrome version",
      "last 1 firefox version",
      "last 1 safari version"
    ]
  }
}
```
 
Image
Louis-Nicolas Leuillet
Le 27/02/2023 à 05:31

Merci beaucoup, tu peux m'envoyer ton code en partageant un lien google drive

Image
Antoine Delamare
Le 27/02/2023 à 17:38

Bonjour et merci pour le retour !

 

J'ai pu résoudre le problème après plusieurs heures d'investigations : le message d'erreur faisait référence à une extension Chrome qui rentrait en conflit potentiel avec le projet React.

 

Le problème est resolu depuis que j'ai désactiver l'extension.

 

Merci encore pour l'intervention et surtout pour les cours qui m'enthousiasment énormément, en ma qualité d'ex-pharmacien ayant tout plaqué pour devenir développeur blockchain.

 

Les cours de renfort JavaScript et React/Next me sont d'une aide précieuse.

 

Bonne fin de journée et à bientot !

Antoine Delamare 

Image
Inscrivez-vous ou connectez-vous pour participer à la discussion.

Informations

Créée le 24 août 2022 12:51
Dernière activité le 24 août 2022 12:51