Discussions

Erreur installation

Image

Hello, 

impossible d'installaer la version 3.29.0. J' ai l'erreur suivante :

 

PS F:\Believemy\Programme Rocket\nextjs\atelier-fanou> npm install next-auth@3.29.0
npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR!
npm ERR! While resolving: protfolio@0.1.0
npm ERR! Found: react@18.2.0
npm ERR! node_modules/react
npm ERR!   react@"18.2.0" from the root project
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer react@"^16.13.1 || ^17" from next-auth@3.29.0
npm ERR! node_modules/next-auth
npm ERR!   next-auth@"3.29.0" from the root project
npm ERR!
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR!
npm ERR!
npm ERR! For a full report see:
npm ERR! C:\Users\Christian\AppData\Local\npm-cache\_logs\2023-08-03T05_33_21_602Z-eresolve-report.txt

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\Christian\AppData\Local\npm-cache\_logs\2023-08-03T05_33_21_602Z-debug-0.log
2 réponses
Image
Louis-Nicolas Leuillet
Le 07/08/2023 à 07:57

Hello

 

Il semble y avoir un problème de résolution des dépendances lors de l'installation de la version 3.29.0 de NextAuth.js. L'erreur indique qu'il y a un conflit de dépendance avec la version de React requise par NextAuth.js.

 

La version 3.29.0 de NextAuth.js nécessite React version "^16.13.1 || ^17". Cependant, dans ton projet, tu as déjà installé la version React 18.2.0. Ces deux versions de React sont incompatibles, ce qui provoque l'erreur de résolution des dépendances.

 

Pour résoudre ce problème, tu as quelques options :

 

  1. Mettre à jour la version de NextAuth.js pour qu'elle soit compatible avec React 18.2.0.
  2. Rétrograder la version de React dans ton projet pour qu'elle soit compatible avec NextAuth.js 3.29.0. Tu peux essayer d'installer une version de React qui correspond à la plage de versions requise par NextAuth.js ("^16.13.1 || ^17").
  3. Utiliser l'option --force ou --legacy-peer-deps lors de l'exécution de la commande npm install pour forcer l'installation de NextAuth.js (je te le déconseille)

 

Meilleure réponse
Image
Christever
Le 07/08/2023 à 09:19

Hello,

merci pour ta réponse. Je suis passé à la dernière version de nextauth. Avec les adaptation nécessaires à faire, mais cela permet de rechercher dans la doc. et de s'adapter :)

Image
Inscrivez-vous ou connectez-vous pour participer à la discussion.
Discussion résolue

Informations

Créée le 3 août 2023 05:35
Dernière activité le 7 août 2023 09:19