Discussions

Erreur fire.auth()

Image

Hello

j'ai une erreur avec fire.auth(): ( j'aurai bienmis une capture écran, mais pas possible apparement ... )

Authentification.jsx:64 Uncaught TypeError: fire.auth is not a function

    at registerClickedHandler (Authentification.jsx:64:14)

    at HTMLUnknownElement.callCallback2 (react-dom.development.js:3945:14)

    at Object.invokeGuardedCallbackDev (react-dom.development.js:3994:16)

    at invokeGuardedCallback (react-dom.development.js:4056:31)

    at invokeGuardedCallbackAndCatchFirstError (react-dom.development.js:4070:25)

    at executeDispatch (react-dom.development.js:8243:3)

    at processDispatchQueueItemsInOrder (react-dom.development.js:8275:7)

    at processDispatchQueue (react-dom.development.js:8288:5)

    at dispatchEventsForPlugins (react-dom.development.js:8299:3)

    at react-dom.development.js:8508:12

registerClickedHandler @ Authentification.jsx:64

callCallback2 @ react-dom.development.js:3945

invokeGuardedCallbackDev @ react-dom.development.js:3994

invokeGuardedCallback @ react-dom.development.js:4056

invokeGuardedCallbackAndCatchFirstError @ react-dom.development.js:4070

executeDispatch @ react-dom.development.js:8243

processDispatchQueueItemsInOrder @ react-dom.development.js:8275

processDispatchQueue @ react-dom.development.js:8288

dispatchEventsForPlugins @ react-dom.development.js:8299

(anonyme) @ react-dom.development.js:8508

batchedEventUpdates$1 @ react-dom.development.js:22396

batchedEventUpdates @ react-dom.development.js:3745

dispatchEventForPluginEventSystem @ react-dom.development.js:8507

attemptToDispatchEvent @ react-dom.development.js:6005

dispatchEvent @ react-dom.development.js:5924

unstable_runWithPriority @ scheduler.development.js:468

runWithPriority$1 @ react-dom.development.js:11276

discreteUpdates$1 @ react-dom.development.js:22413

discreteUpdates @ react-dom.development.js:3756

dispatchDiscreteEvent @ react-dom.development.js:5889

react-dom.development.js:4091 Uncaught TypeError: fire.auth is not a function

    at registerClickedHandler (Authentification.jsx:64:14)

    at HTMLUnknownElement.callCallback2 (react-dom.development.js:3945:14)

    at Object.invokeGuardedCallbackDev (react-dom.development.js:3994:16)

    at invokeGuardedCallback (react-dom.development.js:4056:31)

    at invokeGuardedCallbackAndCatchFirstError (react-dom.development.js:4070:25)

    at executeDispatch (react-dom.development.js:8243:3)

    at processDispatchQueueItemsInOrder (react-dom.development.js:8275:7)

    at processDispatchQueue (react-dom.development.js:8288:5)

    at dispatchEventsForPlugins (react-dom.development.js:8299:3)

    at react-dom.development.js:8508:12

registerClickedHandler @ Authentification.jsx:64

callCallback2 @ react-dom.development.js:3945

invokeGuardedCallbackDev @ react-dom.development.js:3994

invokeGuardedCallback @ react-dom.development.js:4056

invokeGuardedCallbackAndCatchFirstError @ react-dom.development.js:4070

executeDispatch @ react-dom.development.js:8243

processDispatchQueueItemsInOrder @ react-dom.development.js:8275

processDispatchQueue @ react-dom.development.js:8288

dispatchEventsForPlugins @ react-dom.development.js:8299

(anonyme) @ react-dom.development.js:8508

batchedEventUpdates$1 @ react-dom.development.js:22396

batchedEventUpdates @ react-dom.development.js:3745

dispatchEventForPluginEventSystem @ react-dom.development.js:8507

attemptToDispatchEvent @ react-dom.development.js:6005

dispatchEvent @ react-dom.development.js:5924

unstable_runWithPriority @ scheduler.development.js:468

runWithPriority$1 @ react-dom.development.js:11276

discreteUpdates$1 @ react-dom.development.js:22413

discreteUpdates @ react-dom.development.js:3756

dispatchDiscreteEvent @ react-dom.development.js:5889

 

 

Merci

4 réponses
Image
Maxime Delville
Le 06/04/2023 à 19:41

"Uncaught TypeError: fire.auth is not a function"

Image
Maxime Delville
Le 06/04/2023 à 19:43

Tu as bien tous tes imports ?

Image
Christever
Le 07/04/2023 à 05:30

J' qi résolu le problème en changeant les chemins d'import :  ( ça a changé avec firebase 9) 

import firebase from "firebase/compat/app";

import "firebase/compat/auth";
Image
Maxime Delville
Le 07/04/2023 à 16:40

Niquel

Image
Inscrivez-vous ou connectez-vous pour participer à la discussion.

Informations

Créée le 6 avril 2023 18:32
Dernière activité le 7 avril 2023 16:40