Discussions

React 18 Vs React 17

Image

Hello,

 

Pour faire fonctionner Styled-Components, j'ai du downgrad de React18 à React17

 

Voir ce post :

 

https://dev.to/ifeanyichima/how-to-downgrade-from-react-18-to-1702-818

 

4 réponses
Image
Pascal LORIA
Le 27/03/2023 à 11:54 (modifié le 27/03/2023 à 14:08)

Merci de l'info  Chriss.   Apparement y a une manip pour que ca marche en 18.

https://github.com/DefinitelyTyped/DefinitelyTyped/issues/59765#issuecomment-1278928375

 

Image
Christever
Le 27/03/2023 à 13:23

uand j'ai testé , non :)

 

Image
Pascal LORIA
Le 27/03/2023 à 14:12

Apparement y a une manip pour que ca marche en 18.

https://github.com/DefinitelyTyped/DefinitelyTyped/issues/59765#issuecomment-1278928375

 

Image
Christever
Le 27/03/2023 à 14:53

Apparement React18 pose d'autres problèmes avec le reste de la formation. Je reste donc sur React 17.

Mon fichier package.json :

{
  "name": "blog",
  "version": "0.1.0",
  "private": true,
  "dependencies": {
    "@testing-library/jest-dom": "^5.11.9",
    "@testing-library/react": "^11.2.5",
    "@testing-library/user-event": "^12.7.1",
    "axios": "^1.3.4",
    "bootstrap": "^5.2.3",
    "react": "^17.0.2",
    "react-dom": "^17.0.2",
    "react-router-dom": "^5.2.0",
    "web-vitals": "^1.1.0"
  },
  "devDependencies": {
    "vite": "^4.2.0",
    "@vitejs/plugin-react": "^3.1.0",
    "@types/react": "^17.0.2",
    "@types/react-dom": "^17.0.2"
  },
  "scripts": {
    "dev": "vite",
    "build": "vite build",
    "preview": "vite preview"
  },
  "eslintConfig": {
    "extends": [
      "react-app",
      "react-app/jest"
    ]
  },
  "browserslist": {
    "production": [
      ">0.2%",
      "not dead",
      "not op_mini all"
    ],
    "development": [
      "last 1 chrome version",
      "last 1 firefox version",
      "last 1 safari version"
    ]
  }
}
Image
Inscrivez-vous ou connectez-vous pour participer à la discussion.

Informations

Créée le 13 mars 2023 17:11
Dernière activité le 13 mars 2023 17:11