Discussions

6 high severity vulnerabilities -- Aide

Image

Bonojur Nicolas,

 

J'ai un soucis au niveau de la création du projet React, en effet il me dit que j'ai "6 high severity vulnerabilities" lorsque l'installation se termine.

J'ai effectué la manip avec la version --scrpits-version4.0.2  et également sans celle-ci pour tester et dans les 2 cas j'ai ces 6 vulnérabilités qui apparaissent.

J'ai également fais le test sur un autre PC et même résultat.

 

Aurais-tu une idée d'où cela pourrait provenir stp ?

 

Merci d'avance.

 

Cordialement.

 

Antoine 

4 réponses
Image
Louis-Nicolas Leuillet
Le 12/01/2023 à 11:25

Hello Antoine.

 

Il est possible que les vulnérabilités proviennent des dépendances de votre projet React. Il est recommandé de vérifier les versions des dépendances de votre projet et de les mettre à jour si nécessaire. Vous pouvez utiliser la commande npm audit pour afficher les vulnérabilités détectées et des informations sur les dépendances affectées. Il est également possible d'utiliser npm update pour mettre à jour les dépendances à la dernière version disponible qui corrige les vulnérabilités détectées. Il est important de noter qu'une mise à jour peut entraîner des incompatibilités avec d'autres dépendances, il est donc recommandé de vérifier les mises à jour avant de les installer.

 

Image
4.No.NY.MouS
Le 12/01/2023 à 14:14

Super merci Nicolas,

je vais tester ça et et je te tiens au courant.

(  Tu peux me tutoyer, avec plaisir :)  )

Image
4.No.NY.MouS
Le 12/01/2023 à 15:29

Du coup j'ai réalisé un update puis audit et 0 vulnérabilitées détectées donc merci bcq Nicolas !

Image
Louis-Nicolas Leuillet
Le 13/01/2023 à 16:36

Nickel merci pour ton retour !

Image
Inscrivez-vous ou connectez-vous pour participer à la discussion.

Informations

Créée le 12 janvier 2023 10:49
Dernière activité le 12 janvier 2023 10:49